Start a new topic
Solved

CTRL + F does not unhide the Navigation Bar

Hello guys,


to have the highest possible resolution when working with Royal TS, I have the Navigation view docked/hidden to the left side of the screen.


When the Navigation view is hidden that way, CTRL + F does not jump to the Navigation menu directly. The shortcut CTRL + F only works, when the Navigation view was opened via mouse click (hover does not work either). This is very inconvenient to me, as I'd like to hit CTRL + F and then start typing the server I want to connect to immediately. But right now I have to use the mouse as well for that.


In the new hotkeys menu of V6 I have not found a way to do what I want. Any ideas?


Hi Jan,


CTRL + F is quite a common shortcut and if we "hijack" it, you won't be able to use it in any of the remote sessions. What you can do is to assign a shortcut for showing the Navigation panel (default is CTRL + P, CTRL + V) and then use CTRL + F. Note that default shortcut scope requires the app to have the focus. Remote sessions may prevent recognition of the shortcut. You can change the scope of the shortcut to be deep or even global:

https://docs.royalapps.com/r2021/royalts/user-interface/commands.html#scope


As an alternative, you can also try our new global search / command palette feature:

https://docs.royalapps.com/r2021/royalts/user-interface/commands.html


Let me know if this helps.


Regards,
Stefan


1 person likes this

Hello Stefan,


thanks for your reply. Your explanation regarding the unhide makes sense, I have not thought about that.


I have just tried your shortcut CTRL + P,V and this indeed does bring up the Navigation view, however CTRL + F will still not put the cursor into the search field until I have clicked the Navigation view once with my mouse.


As can be seen in the screenshot, the Navigation bar at the top is not highlighted after CTRL + P,V which means that is not focused by the application, therefore the shortcut CTRL + F does not work.


image


I will check the global search you mentioned in your second link.


I have checked the Global Search, but to simply RDP into a server, I'm afraid this is slower than using the Navigation view. But thanks for the suggestion.

Hi Jan,


I checked our current internal release and it seems the CTRL+P,V shortcut is focusing the navigation panel so that a CTRL + F will focus the search box. I can see that there were a couple of changes in the docking logic/behavior so I would kindly ask you to try again once the next minor release has been published.


Regards,
Stefan


1 person likes this

Yes the behavior now works as you described in version 6.00.51005.0

Login or Signup to post a comment