Start a new topic

RoyalTS stays at Top

Hello @all,

sometimes RoyalTS (V6.1.60116) stays at top of all windows, also at the own RoyalTS Dialog windows... So i have to kill the RoyalTS exe from another desktop (since the task manager is also not visible behind the RoyalTS window).

This happen one or more times a day...

Have anyone else the issue or did i use a false configuration entry somewhere...?



1 person has this problem

Hi Marco!

We've seen a hand full of reports regarding this and I've seen it one time myself. Unfortunately we weren't able to reproduce the issue in any way. From what we have seen, it could be a weird issue involving multiple displays and sleep mode - not sure if it's the same situation for you. Maybe there's also some interference with other tools installed on the box which manipulate desktop windows.

If you see a pattern or have repro steps, please let us know.


I have the same problem. Cannot even open options without making main window small

Hi Igor,

sorry that you are experiencing this behavior.

Could you please open a new support ticket via the following link and let us know how to reproduce the issue/attach a screen-recording:

Thanks & best regards,


I begun having the same issue just recently. This is incredibly frustrating as even Royal TS' own pop-up prompts are behind the main Royal TS window, and I cannot access those pop-ups without first resizing the main Royal TS window to as small as possible --> then clicking on whatever (subsequently triggering a pop-up). I have tried reinstalling Royal TS and it worked fine for a few moments but the following day reverted back to its bad "permanently on top" behavior.

I also experience this issue on Royal TSX (Mac), which suggests the issue is more generalised than previously thought.

According to some of our users who experienced this, the issue has been resolved in the latest Windows release. Can users in this thread confirm this?

@Thomas Price: please create a new entry in the Royal TSX (for MacOS) Problems forum.

Thank you!


Login or Signup to post a comment