Start a new topic

Issues with FreeRDP and OpenVPN

Hello all, I have Royal TSX running on an MBP with M1 Pro. I also use Royal TS on Windows. In both versions I use databases synchronized via Nextcloud. So far so good, everything is working fine. As soon as I move outside my network, I have to turn on VPN to connect to my servers at home natively via RDP or SSH, I think this is a normal scenario for many. Once I have VPN turned on, I can connect to my Linux systems via DNS names over SSH normally. (Native via the terminal as well as Royal TSX via iTerm2 plugin). I assume by this working that my configuration is basically fine. If I now try to connect to my Windows based systems via DNS name and RDP via VPN and Microsoft RDP App everything is fine. However, if I now try to connect to a Windows based system via RDP using the FreeRDP plugin via DNS with the same Royal TSX Config that I use for SSH, I only get the message - FREERDP_ERROR_CONNECT_TRANSPORT_FAILED. If I do it at the same time via the Microsoft RDP app without making any configuration changes, I can connect immediately. I have already cleared the DNS cache via terminal with "sudo dscacheutil -flushcache; sudo killall -HUP mDNSResponder", because I thought it might be the problem. If I do the whole thing without VPN in the corresponding local network, everything works fine. Only with open OpenVPN I have problems with Windows based systems via the FreeRDP plugin.

If I adjust my Royal TSX database and use the IP address instead of the DNS name then it works fine with an open OpenVPN connection. Because I use Royal TS/X also for work and there also OpenVPN is used I strongly prefer to use DNS names because I don't and can't use fixed IP addresses in every environment.


I believe that the workaround (disable TCP keep-alive) described in the following link will resolve your issue:

Please let me know if this helps!

Login or Signup to post a comment