Start a new topic

Add support for kerberos to RDP

Hi, 


It looks like FreeRDP now supports kerberos but it needs to be enabled at compile time.  Could you please add kerberos support to FreeRDP?


Kind Regards,


Tristan


3 people like this idea

Hi Tristan,


we'll definitely look into this once the feature is available in the stable branch. Currently it's only in the experimental/development 3.0 branch, not in the stable 2.x branch.


cheers,

Felix

Hi Felix,


Thanks for the response.  I didn't realise that kerberos support has only been added to the 3.0 branch.  I'll keep an eye out on future releases.


Kind Regards,


Tristan.


Hi,


Just wondering, has this been released for TSX? my colleague uses a Mac and needs to use kerberos to connect to our windows machines through RDP.


We have the accounts set up, just need to figure out if theres a setting we need to change in royal for it to use kerberos rather than NTLM.


Thanks!


Liam

Hi Liam,


my comment from February still holds. While Kerberos support is available in the development branch of FreeRDP (3.0), it's not yet in the stable branch.

Once FreeRDP 3.0 is released and stable we will look into supporting this in Royal TSX as well.


cheers,

Felix

Hello Felix, 

It looks like FreeRDP 3.0 has been released and can be considered stable. When might we expect some information about Royal TSX updating to 3.0?


Thanks, 

Zach

Hi Zach,


we're already working on upgrading to 3.0.0. Unfortunately we discovered some regressions (mainly with the graphics pipeline) which we're currently trying to iron out with the FreeRDP team.


cheers,

Felix

This will be a milestone enabling rdp with nla and hopefully Smartcard + nla support

Hi Benjamin,


The current beta Royal TSX V6.0.3.1 comes with FreeRDP V3 and should support NLA + SmartCard.

You can download it via the following link:

https://www.royalapps.com/go/kb-ts-mac-downloadbeta


I hope this helps!


Best regards,

Christoph

Hi Christoph, Thanks for the hint! I will try it out asap

Am interested in getting NLA + SmartCard working in our environment, and so far, haven't had any luck with the latest beta (v6.0.3.1) mentioned last week.

Only way I have been able to get a connection is to disable NLA on the Windows system.

Any suggestions on how to get this working? 

Hi Dan,

in order to figure out what is causing this issue, I would ask that you enable debug logging, reproduce this issue and send us a log file via a support ticket which you can open here:

https://www.royalapps.com/go/support-ticket-new


You can enable debug logging by following these steps:

- Go to "Royal TSX - Settings - Logging - File Logging"

- Make sure "Enable File Logging" is checked

- Set the "Logging level" to "Verbose"

- Note the "Logfile path" since you will need it later on (or open Finder, navigate to the path right away, and keep the window open)

- Apply the changes

- Reproduce your problem

- Locate the log file on your file system and include it in your ticket


Since debug logging heavily impacts performance, you should always disable logging after you're done reproducing your problem.


Thanks!


Hi Dan and everyone


I've also replied to your ticket but will also reply to this thread for others to see:


We've just released a new Royal TSX Beta, which comes with the Kerberos functionality.


You can download the latest Beta here:

https://www.royalapps.com/go/kb-ts-mac-downloadbeta


If any issues occur, please let us know.


Best regards,

Christoph Mühlberger

Thanks for the update! @Dan I would like to hear if you get it running, because i am also very interested. Thanks in advance! Benjamin
Login or Signup to post a comment