Start a new topic

[RoyalTS v7] Color Palette Overwrite Not Working Globally For Putty Terminal Plugin


I recently upgraded from RoyalTS v6 (portable) to v7 (portable) and I face the issue, that I can't overwrite my putty terminal color settings anymore. 

Steps to reproduce:

1) Set putty as you default terminal plugin: 

    View -> Plugins -> Terminal -> Terminal (Based on Putty) -> Set to default

2) Test a ssh-connection - background should be black:

3) Change color palette for the plugin: 

    View -> Plugins -> Terminal -> Terminal (Based on Putty) -> "Press the little dropdown arrow" -> Overwrites -> Colors -> Palette -> Choose e.g. Solarized

4) Save + Restart RoyalTS

5) Test a ssh-connection - background is still black

Changing the colors per ssh-connection works:

1) Right-Click your ssh-connection -> Properties -> Colors -> Palette -> Choose e.g. Solarized

2) Test a ssh-connection - background is orange

Is there another global setting to change the colors in the RoyalTS v7 putty plugin which I did not see? Or is this a bug?

Best regards


You're welcome! Glad I could help.

Hi Stefan,

thank you for the hint.

I changed:
View -> Options -> Behaviors -> Modifiers -> Dropdown: "Always apply, except when holding the Alt key"

Now it works perfect :)

Best regards,




Hi Gudrun!

By default, overrides are only applied while holing the Alt key while connecting. You can change this behavior here:

Does this help?


Login or Signup to post a comment