Start a new topic

File Transfer (SFTP/SCP) not asking for Credentials


File Transfer works fine if i saved my credentials in a terminal connection (rebex or putty). 

But if i don't save my credentials (i like to manually put in my login+pw everytime i connect to a server) a file transfer fails because of a "incorrect username or password" or " String cannot have zero length". I tried two methods...Connect with Options and Connect using Template.

When i choose Connect with Options there is a option called "Prompt for Credentials". But it makes no difference if i activate this option or not.

I think this must be a bug!?


Sorry for opening old ticket but I have the same problem on Royal TSX 3.2.4 on macOS 10.13.1

works as expected.

thank you!

Any News? I still have the same problem. :(

If i choose "connect with options" it makes no difference if i activate the option "prompt for credentials" or not. Everytime i got the error: String cannot have zero length. 

My Credential Setting for SSH Connection: "Do not use any Credential"

I agree, Robert. That requires much more effort from our side. Since the original question has been answered/solved, can you create a new feature request for that? That would be very helpful for us to keep track of our backlog.

Thank you,

Hi Stefan,

it would be nice, if prompting for public key passphrase work too. (like putty session)



Hi Sven,

thank you for the feedback. The next release will prompt for credentials automatically if no credentials are specified.


1 person likes this
Login or Signup to post a comment