Start a new topic

Having Trouble While Installing Royal TS

Greetings to all, I am a new member on this forum and I recently tried to install Royal TS, version 6.1 on my Windows 10 computer. But after completing the installation process, when I try to launch this software, I came across the following error:

"The application was unable to start correctly (0xc0000022). Click OK to close the application."

I do not understand what could be the issue. Does anyone have any idea about this issue? Please help




can you examine the event log (Application or System) and see if there's a clue what's going on?



System : 11th Gen Intel(R) Core(TM) i3-1115G4, 64-bit

RAM : 8.00 GB


Did you find anything in the event log?

Yes, there is showing a lot of administrative event errors. Yesterday when I checked it, I did not get this huge amount of errors. I even dont know if there is any reason for this issue related to those errors.

Can you post a couple of screenshots or more information about those errors. I'm also not sure if it's related but I can't really help if I don't get more details. If you aren't comfortable posting this here in a public forum, feel free to open a support ticket here to continue the discussion in private:



I was searching online related to this issue and came across this useful guide. I run SFC scan which was mentioned in the article. After doing the task properly, the problem got solved. Now I have no longer any issues while working on the software.

Though I don't know whether it is a permanent method. But right now I am working fine here.


Thanks for letting me know. Glad it's working. Please do not hesitate to contact us if you run into any issues.


Login or Signup to post a comment