Start a new topic

UltraVNC slow to start

Royal TS 6.0.51119 (Portable mode)

UltraVNC Viewer (tried also

Computer: 32GB RAM/Ryzen 5 5600X/W10 Pro 21H1

Hello, I purchased Royal TS to replace mRemoteng. I have a problem with UltraVNC, specifically, it takes 7-8 seconds to connect. In RemoteNG, UltraVNC viewer (vncviewer.exe) starts instantly.

With debug console enabled, i can see the following (the delay is the same, 7-8 secodns no matter what options I change):

1/13/2022 1:20:17 PM - Debug - Connect - Connection manager for TEST_CLIENT has been started.
1/13/2022 1:20:17 PM - Debug - Connect - Query main credentials for TEST_CLIENT.
1/13/2022 1:20:17 PM - Debug - Connect - Resolve credentials for TEST_CLIENT immediately.
1/13/2022 1:20:17 PM - Debug - Connect - Credentials for TEST_CLIENT has been resolved.
1/13/2022 1:20:17 PM - Debug - Connect - Query connect task for TEST_CLIENT.
1/13/2022 1:20:17 PM - Debug - Connect - Uri for TEST_CLIENT has been resolved: CNEW33.SIELMAN.LOCAL.
1/13/2022 1:20:17 PM - Debug - Connect - Query connection client for TEST_CLIENT.
1/13/2022 1:20:24 PM - Activity - Connect - Connected to TEST_CLIENT

 I have also tried to start unattached, the delay is the same.

Arguments used (mRemoteng vs Royal TS):



Is there anything I'm missing? Are there any plans to optimize this feature?

Thank you


How long does it take if you run UltraVNC directly (outside of Royal TS) with the same parameters?



So I moved the portable installation to another pc, a HP Elitebook 840 G3 (Intel i5-6300u/16GB RAM/NVME SSD) with Windows 10 20H2. The result is exactly the same, a 7 second delay when starting an UltraVNC connection. So it seems this delay is not due to processing power since this is a quite slower and older CPU but the delay is exactly the same. UltraVNC and Royal TS versions are the latest available.


There is virtual no delay if:

1) I start vncviewer.exe from file explorer and use dialog to connect

2) if I create a batch file with the exact same parameters and run in from command prompt

3) if I create a task in Royal TS that runs vncviewer.exe, and start the connection that way

I have captured a video showing the exact situation with verbose logging enabled:

Only thing i haven't tried is to install Royal TS to program files, not use it as portable app, but i doubt it will make a difference.



This is really odd. I'm not able to reproduce this "delay" on my systems. I tried with the same settings as you do but without the -dsmplugin parameter. For me it starts within a second or so, even though I have to establish an SSH tunnel upfront to my test system. What's even stranger is, that running "unattached" has also a delay for you. This is strange because all what Royal TS is doing is to simply invoke the command without any logic ensuring that the window is embedded. I'm not sure what's causing this, especially since you tried that on two different systems.

Btw. thanks for the awesome video. I really wish more users are providing such great details documenting their issues. Very delightful!

Hello Stefan!

I'm really glad that you took a look

I think I found the problem, it seems to be connected to UltraVNC but it can be solved with a very small modification in Royal TS code.


  1. You were right about the delay appearing only when the encryption plugin option is used. When the encryption plugin is not specified in the arguments, UltraVNC starts without delay.
  2. With Sysinternals Process Monitor, I found that Royal TS uses this kind of command to start UltraVNC:
     "D:\Dropbox\RoyalTS_6.00.51119.0\_apps\ultravnc\vncviewer.exe" TEST_CLIENT:55948 /password "XXX" /autoscaling /normalcursor /disablesponsor /nostatus /dsmplugin SecureVNCPlugin64.dsm

  3. I copied the exact above command to a cmd prompt and ran it, and i encountered the exact same 7 second delay, so the problem is not related to Royal TS, but somewhere in the above command
  4. After some tests, the "/nostatus" flag seems to be the problem. If you start UltraVNC without the "/nostatus" flag, it starts immediately.
Conclusion: When using the UltraVNC encryption plugin (SecureVNCPlugin64.dsm) and the "/nostatus" flag, UltraVNC has an approx. 7 second delay to connect. Unfortunately, in Royal TS there is no option to enable/disable the "/nostatus" flag. I have already reached out to UltraVNC developer, but i am unsure if there will be any resolution from their side.

Can you please add a checkbox in VNC Advanced Options for the "/nostatus" flag?

Thank you in advance!



interesting find! The next release will have an option to enable/disable the nostatus flag.


Looking forward to it, thank you!

Login or Signup to post a comment