Start a new topic

Occasionally getting error when using CLI to connect to machine


I started using the CLI to connect to machines and I'm occasionally getting this error pictured below.


Royal is currently running, and my document is open with many VM's in the nav tree. If I execute a similar command to the one circled above for a machine that is  currently on, but a different name than above, it will work. If I execute the line above as is, and this machine is currently off, it 'may' try to connect and then not connect and everything is OK. Or it may throw this dialog up. I was only able to get this dialog to appear if I tried to connect to a machine that is NOT on. However, once I received this error, I would get it almost every time even for machines that on.

AND the problem is that when this dialog appears, it locks up the command window. It doesn't return until I manually close this error message.

Also, there is no %ERRORLEVEL% returned other than 0. How can I tell in the batch file that the connection was not successful?



Just to follow-up with more info on my report above...

I've automated a process to restart Azure VM's and then once they have been restarted and I've waiting 2 minutes to ensure all the VM's are up and running, I start iterating through all the VM's and executing the line of code circled above (only the machine name changes as appropriate). If I have just restarted Royal, it works for the first few machines, and then I start getting the same error as reported above. And from that point onward, none of the connections will work. Also as mentioned, when that error appears, it locks up the process until I manually click "don't send"


I put a delay in between the iterative calls to the machines of about 30 seconds, and it started working. To be clear, before the delay was added, there was still about 15-20 seconds in between calls, but I guess something is going on that needs to work itself out before the next call and that wasn't enough time.

I'm back to contradict myself... It doesn't work. It flip flops between not working as originally posted, and 'working'. But 'working' actually is not really correct because it is leaving a royal process running for each attempted run and also the rtscli process is still running too, and all the command windows to start the processes are left open. Not sure why that happens... 

So I'd really like to hear from someone on this if possible. Maybe there is more info I can provide if you tell me what you would like to see?



Login or Signup to post a comment