Start a new topic

Very Slow/Laggy after some time

Hi All,

Looking to see if anyone else has experienced similar issues. This has happened to me for quite some time - over a year, but I've been too lazy to report it.

Basically, it seems that after an extended period of time (several days) the RoyalTS app window becomes almost unusable. Moving the RoyalTS main window around the monitor or between monitors is very slow. I will click to drag the main window around and it takes 5-7 seconds before the screen follows. Also, moving between connections/tab in the interface is extremely slow. After clicking a tab it takes 3 - 4 seconds before the screen changes and the tab will accept input. I predominantly use RDP to 7-10 servers as a time and those connections might remain open for days.

Closing/reopening RoyalTS will resolve the issue.


Hi Riley,

I have to admit that my instance doesn't run longer than a day or two but I haven't seen this myself. Can you provide some numbers from the task manager (memory usage / private bytes) when you started Royal TS and the same when it becomes laggy? Maybe there's a memory leak which causes the slowdown.


I've been monitoring this some more and it seems to be the tab bar where the issue lies. When the issue happens anything to do with that bar becomes very slow. For example, just moving the mouse across the tabs you can see the tab highlighting following far behind the cursor and it skips most of them. If I move my mouse up to the bar then it's a good 2-3 seconds before the tab will highlight and can be clicked.

When switching between RDP sessions I counted ~5 seconds from the time I click on a tab to when that session will accept input. This is with ~14 RDP tabs open. As I close them the performance gets progressively better until it becomes acceptable with 3-4 tabs open. This RoyalTS window has been open for 3 days with the number of tabs varying from 7-14.

With 14 tabs memory usage was ~3400MB and CPU usage stayed at 0%. Switching between tabs CPU usage would move to 14% or so for the 5 seconds until the tab would accept input. Just moving the cursor back and forth over the tabs will cause CPU to stay at 10-12%.

System Specs:

 - AMD Threadripper 1900

 - 32GB RAM

 - NVidia GTX1600 3GB

 - 500GB Samsung SSD

 - Windows 10

1 person likes this


I'm having a hard time to find that many connections to test. I can see that switching tabs (even if I only have 3 or 4 open) can be a bit laggy when the window is maximized on a 5k screen running Royal TS DPI aware - regardless if it's RDP or web or some other connection. When I reduce the Window size to a quarter of the screen, it's snappy. Can you see the same effect? I'm assuming this is because Royal TS is a WinForms (GDI) based app which doesn't take advantage of hardware acceleration.

Also, your first post mentioned that this only happens after several days. In your second post you mentioned 3 days of Royal TS running. Do you see this lag only after a couple of days or immediately when you have 14 tabs open (right after a fresh start)?

So, time doesn't seem to have as much of an effect as I thought. I think I was bringing time into it because as time goes on I would add more and more connections. However, The other day I opened ~15 RDP sessions within a few hours and it was very slow. So, it seems to be the number of connections open.

Right now I'm working with only two and it's perfectly acceptable. However, just a couple hours ago I had 10 or so open and it was slow. I tried resizing the main RoyalTS window and it was very laggy. If I turn off the "Show window contents while dragging" then I can resize without too much of an issue - it still "freezes" for 5 seconds or so after I resize the window.

If I switch tabs in succession it will lag bad enough that sometimes three of the tabs are "lit up" like I'm hovering over them. Also, the menu tree on the left will freeze and become unresponsive at the same time.

With "Show window contents while dragging" enabled then it's very difficult to resize the window. The whole RoyalTS window will "flash" as it resizes and you can see the screen redrawing. The action lags behind the mouse quite far. 

I have two 27" 1440p monitors. I resized the window to be much smaller and if it did help it wasn't much. Maybe the connection accepted input a bit quicker? 

Sorry for the delay, Riley. I'm still struggling with reproducing the issue using 15 or more connections. But I checked the code and there are some things which you can tweak to maybe speed things up.

* Check if all your RDP connections are setup to use Smart Reconnect in the connection properties under Display Options. If so, please change it to Smart Sizing or Scrollbars. The Smart Reconnect option requires a background thread which will check for size changes on a regular basis.

* Alternatively: Go to the View ribbon tab and click on Plugins. Open the Settings of the Remote Desktop Protocol Connection. Make sure the option "Force Smart Reconnect on all Sessions" is disabled.

* Under Advanced -> Performance: check Hardware Acceleration

* Open the View -> Options dialog and navigate to User Interface -> Tabs. Make sure "Enable Taskbar Thumbnails" are unchecked.

* Also in the Options dialog under "Troubleshooting", check the "Delete EasyHook DLLs" and click on Reset Settings. Without those DLLs we don't do "live" previews for the Thumbnail view. With many connections open, this can be a performance bottleneck.

To change those settings on multiple connections simultaneously, use the bulk-edit feature in Royal TS:

Please try the above and let me know if this improves your situation.


Hi Stefan,

I bought the software a couple days ago because I found it very useful and it worked well.

However, I have the same problem described here. I changed the parameters as you asked in your post but it didn't changed anything. 

I have 3 RDP sessions and 3 website open. Royal TS takes already 2,3GB of ram and switching between those sessions takes 5 secondes which is unusable. It's very laggy.

I don't know what I can do, I'm disappointed to be honest. 

What solution can you bring ? 

Best regards,



Sorry for the double post. Just to say that I have found my culprit -> I checked "disable display scaling on high DPI settings" in Options/User Interface/User Interface/General. I'm on a 27 inch 1440p display so now it's a little blurry but waaaay snappier !

Weird that I didn't experience that when I tested the software without the licence btw...

Best regards,


Hi Robin,

I'm sorry for your frustration. As you all know by working in IT, problems like this can be hard to track down and we rely heavily on detailed data from our customers to find out what's going on - especially when we cannot reproduce the issue on our side.

You write you have 3 RDP and 3 websites open. It would be helpful to not mix those things up unless they are really only happening if both connection types are used simultaneously.

Could you check if you see this behavior if you only have 3 RDP connections without the web pages or if you only have 3 web pages without the RDP connections?

Are you running a 64 bit OS or 32 bit OS?

I'm assuming that your web pages are using the Chrome based plugin. If so, it's a well known fact that Chrome is a memory hog and when Royal TS hosts those web browser, it will also need to use that much memory.

For RDP, a single connection can take up to 250 MB or even more (depending on color depth, resolution and features used in RDP).

We also had some issues in the past where another software is interfering with Royal TS or more specifically with the RDP sessions in Royal TS. For example, VMware Player could cause performance issues or memory leaks as well as some utilities (like MultiMon Tools) which are drawing controls over the Windows title bar. It would be interesting if you can reproduce this behavior on a vanilla machine where no other system utilities or tools are installed which potentially can interfere.

If you can provide more information on how to reproduce the issue on our side, I will do my best to track down and fix the issue. I'm really sorry for the inconvenience and I hope we can find out what's going on.


Disabling display scaling could be an issue on high res displays. Royal TS is a "WinForms" app mostly with GDI rendering which is not hardware accelerated. There is an option in Royal TS which allows you to enable hardware acceleration for RDP (in the Performance settings of the RDP connection). Maybe this will also help. Would be interesting if you can try that and report back if that improves performance.



Hi Stefan, 

Thank you very much for the fast answer !

I'm running Windows 10 Pro 1909 64bits. The issue is not really the memory usage, I have 32gb so it's ok. The real problem is the connection switching which can be laggy. 

As I said, I had much improvement disabling the high DPI. It was better and way snappier with 5-6 RDP session. Problem appeared again with the web pages. As soon as i have a web page connection opened, switching between tabs becomes really slow. 

So I started looking into the options. I discovered that the default is internet explorer -> I switched to chrome engine. It's been half an hour -> no more lag. Seems to do the trick. 

I have activated Hardware acceleration to all my rdp connection, as you suggested in your earlier post. I also deactivated the Smart sizing, I'll look to reactivate it has I find it very useful (for now I put everything in smart reconnect, which is still ok), see if it's still ok with it.

Again thank you for your answer, I hope you'll find the origin of the problem :D (I think it's about the internet explorer engine, maybe not have that has default ?). I'll do more test over the week-end, see if I can really pin point what is the cause.

Best regards,


That's interesting. I wouldn't have imagined that the Internet Explorer could cause this lag. We actually did switch to the Chrome engine as default but it turned out to be problematic because it spawns child processes and in some (Enterprise) environments it doesn't work correctly and can even cause a crash. Even Edge is not an option because the runtime distribution which is required is currently a nightmare.

I'm looking forward to see your test results.

I have the exact same problem.  I leave RoyalTS running for weeks (it is the shell in which I do all my daily work).  It becomes very sluggish, and I can see the taskbar stutter when sliding out because something is slowing the system.

I'll check for hardware acceleration on each RDP session, and deactivate smart sizing (if possible).  But a default/automated fix would be helpful.

Can you provide some numbers (CPU, memory utilization, number of threads/GDI objects). You can find these numbers in the details view of the task manager. You may have to add some more columns though.

Same problem here. I'm connecting to two machines.

Machine A is connected to LAN.

Machine B is in Azure.

Using Royal TS, MachineA is responsive but MachineB is not. When using MS RDP to connect to MachineB, everything is smooth.

Login or Signup to post a comment