Start a new topic

RoyalTS Overrides and logs

Hi,

It seems that overriding logging doesn't work. 


If I'm defining the override directly on the devices it works, But if I'm using override nothing happens. 


Issue is on RoyalTS and TSX


Hi,


by default, overrides are only applied when holding the ALT key while connecting. You can change that behavior in the Options if you like. See:

https://content.royalapplications.com/Help/RoyalTS/V5/index.html?reference_options_behavior.htm


Let me know if this helps.


Regards,
Stefan

I know that I changed the parameter to apply it by default.


I know it's applied because I have the coloration highlight enabled by the override.


Take the time to try it on your hand you will see, It's not working

I just tried to reproduce the issue and here's what I found out:

* the override actually works (when applied). A log file will be written and can be seen using the file explorer at the location of the override log directory.

* since the log directory is configured in the override but not in the connection itself, the dashboard actually doesn't know where to look for the log files, hence you don't see them.

* overrides are only applied when connected. the dashboard shows data according to the configuration of the connection when not connected.

* if you want to see the log files in the dashboard as well, you need to configure logging on the actual connection, not the override.


I hope that explanation makes sense.


Regards,
Stefan

I understand but we can't define the log in the connection directly as it's shared with the rest of the team.


As some people are on Windows and some others are on Mac we can't define it directly on the object.


Something that you could improve in your next release ;)

Hi Cyriel,


as mentioned in my previous replies, the best way to handle this is by using overrides.


We are open for suggestions. If you have a proposal how we can make this feature better, please let us know.


Regards,
Stefan

Login or Signup to post a comment