Start a new topic

Any way to prevent ssh timeout?

I'm trying to keep certain terminals logged in on some Cisco network devices. They have a set exec timeout setting to kick me out if no inputs are detected. I tried getting keepalives to work but they appear not to be doing what I want. I've seen some terminals that will send a specified character to all open sessions in set intervals. 

Is there anything that is built into royalts that might be able to do this for me?

Hi Kyle,

may I ask what keep-alive intervals you tried? Is the interval perhaps too long?

The last one I tried was a keep-alive every 1 second which does not work. My timeout is 15 minutes.

where is the keepalive option?

Hi Jeff,

for rebex based SSH terminal connections, the keep alive setting is a plugin setting. See:

PuTTY based SSH terminal connections have a setting in the Advanced settings page:

Let me know if this helps.


Login or Signup to post a comment