Start a new topic

Chrome Key Sequence not working since update

Hi,


since Update 5.0.61428 Key Sequences are not working anymore on Web Page Connections (Chrome)


image


I think the web page does not get the focus since the key sequence will run outside of the web page and is changing stuff in the royal ts interface


3 people have this problem

Thanks, I already downgraded to 5.00.61330.0 and told my colleagues to avoid any update for the time beeing.

Thanks for the quick reply.

In our tests, it works fine. Is it possible that the delay is too short? Can you provide an URL we can test against?

Thanks for looking into this. I'm available to do a screen share if needed. Cheers

The strange thing is - it's mostly started working all of a sudden, apart from the enter key which I can work around as you've mentioned above. I can't think of anything on the machine that has changed... I'll keep an eye on it.

Confirmed Chrome Web Page key sequence tasks don't work in v5.0.61429. Changing your plugin to IE works. Key Sequence Broadcaster doesn't work at all though. I created a separate post, which should be available shortly.

Please download the latest release (5.0.61707) and give it a try. The chromium component was updated in this release which should fix all the focus related issues.

https://www.royalapplications.com/ts/win/download

This might be off topic, but is somehow related: you know what would be super helpful? Having a right click option to invoke the sequence when the external window like the Chrome one has focus. Having to switch to RoyalTS, clicking the sequence then hoping it'll focus back to desired window is finicky. 


It's related to this issue, because this option would be at least a nice workaround when the autotype and focus don't work well as in newer builds then 5.00.61330.

I think its hard to reproduce because sometime it works, and sometime it doesn't... so I think it could also be some problem with other apps running, ssh tunnel speed, or something else...

Still not working... here are some Steps to reproduce:


I've attached an example page to try. (copy of the vmware vCenter login page)


Autofill does not work for this page so I've created a Key Sequence:

{WAIT:2500}$EffectiveUsername${TAB}$EffectivePassword${TAB}{ENTER}


Username + Password is set set to "test"

Engine: Chrome (Dedicated, but non dedicated doesn't work also)


The key sequence enters "estest" in the first textbox and then a context menu pops up on the top left corner of Royal TS. (see screenshot)

image



htm
(6.56 KB)

Hi Patrick,


I just tried to repro the issue but failed. It seems to work fine for me. Can you create a new web page connection in a new document from scratch and set it up so that it fails. Once you have done that, open a new support ticket with the document attached and your default settings by attaching the file %appdata%\code4ward\code4ward.RoyalTS.UserPreferences.config.


Thanks,
Stefan

Watch out for the next minor upgrade in the upcoming days. The issue should be fixed then...

I got the same error with version builds 61428, 61429, 61707. Now, I'm back at 61330 again.

But with this version I still have problems with VMware vSphere Center and Hypervisor web interfaces older than v6.7 in combination with key sequences of Royal TS build 61330 Chrome engine.

Any update on this? Build 61330 is the last working version - containing different bugs. The most annoying failure (non-working key sequences inside the Chrome plugin) are still part of all newer versions up to build 61707.

Has anyone found a fix for this?  I am having the same problem.  Even downgrading does not resolve the issue.  So far, support has not offered a solution.

No resolution as of now that I'm aware of. I can confirm it appears that key sequence tasks do not type inside the window that should be in focus and that something in the upper left-hand corner of the screen is selected. If I immediately select the window that should be in focus, key-sequence broadcasting executes as expected.

Login or Signup to post a comment