Start a new topic

RoyalTS 6 Startup Auto-Resize Issue

Somewhere in the lifecycle of RoyalTS 6, the application has started to auto-resize after it first opens. The application will start fully maximized, but then seconds later resize itself down to a non-maximized size. The odd thing is that the RoyalTS app title bar shows the app state as maximized. To fix it, you have to un-maximize the window then re-maximize it. This behavior will repeat itself every time you open RoyalTS 6. I am currently running v6.1.60731. I am uncertain when this started, but it was at least present in the 6.0 versions. To be clear, the multiple monitor position is remembered perfectly fine. The app just resizes itself down after startup.

My Windows version is Win11 Enterprise x64 22H2 22621.2134. I noticed the behavior back in Windows 10 as well.

I have tried removing my saved RibbonSettings-6.xml and UserPreferences.config file in the local roaming directory. This did not resolve the issue though. It simply removed items I had saved in my RoyalTS left nav.

Is there any way to resolve this issue via a setting or is this a bug? It is extremely irritating. This is the first major complaint I have had about RoyalTS products (which are normally very solid).

Apologies if this posted multiple times. I tried to submit it before but it never showed up.

1 person has this problem

In case anyone runs into this, DisplayFusion taskbars have a setting for pinned taskbar items to force an app to start on the same monitor. Disabling this corrects that issue as Royal TS has its own logic to preserve previous monitor, position and size.

Any thoughts, or should I just open a support ticket? I did accidentally create two dupe topics, but this is not solved. I marked the other as solved since I am unable to delete it.

Login or Signup to post a comment