Start a new topic

Problems with Windows Server 2008


we are currently using the Beta Version of RoyalTS and establish connections to Windows Servers over wfreerdp which is using a SOCKS5 proxy. Everything works fine with this setup except the connections to Windows 2008 Servers. After the connection you can see the screen but you are totaly unable to do anything, the remote machine is totally freezed. For test purposes I downloaded freeRDP and tried to connect to the servers by my own and everthing worked. So I guess it has nothing to do with our servers or freeRDP.

Do you have any ideas what could be the reason for this behaviour?



1 Comment


can you try the wfreerdp.exe which ships with Royal TS? Once you open a connection you should see the executable in %temp%. Use that one to test against your server.

If that one also works as expected it may be related to the way we embed wfreerdp.exe. We are utilizing the /parent-window argument to redirect drawing and input handling to a different window handle (inside of Royal TS).


Login or Signup to post a comment