Start a new topic

Frustrations migrating from mRemoteNG

Hi! I use SSH constantly for work with around 200 saved sessions. A couple people have mentioned in the past I should try out RoyalTS as it's more "solid", so I did, bought a license and everything. However trying to migrate my workflow has been quite a pain, even after manually updating the credentials for ~200 sessions (RoyalTS does not support credential import from recent versions of mRemoteNG, so that was fun). 

1.  There seems to be no option to enable the classic SSH behavior of auto reconnecting to dead sessions/rebooted boxes? With MremoteNG, Putty, Kitty, etc, if I reboot a box and the session dies, the window still lives, and once the box is back, I can click in the window and it will automatically log back in to an active session, using previous credentials and everything. RoyalTS seems to be the first client I've used that doesn't do this. I found the option to keep tabs open/alive when the session dies, but they won't reconnect when the box is back. I have to manually right click on the tab, hit reconnect, then it will come back

2. RoyalTS is completely incapable of connecting to SSH servers that start with password auth, then request keyboard-interactive auth as well. A lot of embedded appliances do this for some reason (don't as kme why), IDRAC7 and IDRAC8 Dell IPMI being a big example. I SSH to IDRAC units a lot for work, and RoyalTS is incapable of doing it. It negotiates the password auth just fine, then when idrac prompts for keyboard-interactive auth, RoyalTS doesn't show me or let me do it, it just pops up the credentials box again (and filling it out doesn't work). In Putty, Kitty, and mRemoteNG, this is handled automatically, they just automatically re-send the previous credentials again when it prompts for keyboard interactive, and I don't even notice it happening. This alone is preventing me from using RoyalTS for work. Below is example output from logging in via putty, it's all handled automatically:


login as: daria
daria@xxx's password:
Further authentication required
Send automatic password (Using keyboard-interactive authentication)


Note that I tried switching the SSH plugin to Putty in RoyalTS, but it still will not login

3. There's no way to specify "where" sessions will open in RoyalTS. In mRemoteNG, I typically had a grid of 4 panes, and saved with each session was the pane name where the session would open up. So I could launch mRemoteNG, open 20 sessions, and they would all go to the right pane off the bat, I never had to move anything around. This isn't possible in RoyalTS, in fact it doesn't remember where sessions were at all. I make my nice grid of 4 panes each with about 5 tabs/sessions, but if I ever restart royalts, it's all lost - it just opens up 20 sessions in one giant pane/tab bar, and I have to sit there and reorganize everything, every time I launch RoyalTS

I'd like to migrate to RoyalTS as some other areas do seem polished comparatively, but these have slowed me down quite a bit to the point I'm just using mRemoteNG still and may return my license if that's possible. Hopefully some of these are just user error and are indeed possible!

1 Comment

Hi Jon,

sorry to hear you are having troubles switching from mRemoteNG.

1. You are right, at the moment we don't have auto reconnect for SSH connections based on the Rebex plugin. Since you mentioned mRemoteNG can do this with PuTTY, I'm wondering how you manage to do that. I just tried it and I don't seem the behavior you are describing.

2. Did you try the PuTTY based plugin in Royal TS? It should behave the same way as in mRemoteNG, I guess.

3. We are aware of that and unfortunately we can't really implement a similar behavior at the moment because we use a different UI framework which doesn't have the needed features. We are always looking at alternatives and if we find something where we can improve this behavior, we will implement it. The framework mRemoteNG is using can't be implemented for other technical reasons.

If you like to request a refund, please go ahead and open a support ticket here:


Login or Signup to post a comment