Start a new topic

Unable to open more than one adhoc terminal from ribbon

 When I customize the ribbon to have an adhoc field for quick terminal sessions I can only open one at a time.  If I use it to open an adhoc terminal, attempting to open a second one fails to let me select type from the selection menu unless I close out the first terminal.  This used to work 2-3 patches back.


Hi Jason,

I tried a couple of ways to open terminal ad hoc connections but I'm not seeing the issue you are describing here. Maybe I'm not doing it the same way as you do. Can you please provide as much details as possible on how you customized the ribbon and how you create the ad hoc connection? Maybe a short video as well. If you aren't comfortable posting videos here, feel free to open a support ticket here:

I just added the ad-hoc connection box to the quick launch bar (sorry I said ribbon before) so I could type in an IP and hit enter, which normally brings up a selection dialog to choose how to open that connection



This works fine the first time.  If I try to open a second, that selection dialog will flash and disappear, preventing me from selecting the connection type.  I did discover that if I add the "dashboard" back so I have another tab to select I can get a second ad-hoc to open if I have the dashboard tab selected instead of the terminal session tab.  So I at least have a work around for this.

additionally, using CTRL+ENTER seems to work fine as another work-around

Thanks for the details. Putting this in the QAT will only work if you also put the button below (with the popup menu) into the QAT. Can you try that and see if this resolves your issue?

    Putting the button in doesn't resolve the ENTER selection dialog failure for the additional ad-hoc windows, but I can click it to open additional sessions.  The behavior of typing an address and simply pressing ENTER, regardless of open number of sessions or selected tab used to work at some point in the past, but at least I have a few options figured out for going forward.

    In Summary:

    • typing an address and pressing enter brings up session type selection on initial connection
    • typing an address and pressing enter doesn't work for subsequent sessions unless I select the dashboard tab first
    • typing an address and pressing CTRL+ENTER works by defaulting to previous session type, regardless of which tab is currently selected
    • typing an address and clicking the session button also works regardless of which open tab is already selected.

    Hi Jason,

    I'm still not able to reproduce the issue using your steps. Works flawlessly on my machine. Can you please try to reset your configuration file?

    - Close Royal TS

    - rename the file %appdata%\code4ward\code4ward.RoyalTS.UserPreferences.config

    - Start Royal TS and adjust the quick access toolbar again

    Let me know if this resolves your issue.


    Slight change to that path, that config file is in the Roaming folder of %appdata%.  


    After renaming that file and opening RoyalTS up I was back to defaults, re-customizing the UI back to what I had before and re-testing resolved that glitch.  The ad-hoc box on quick launch works consistently when opening multiple different terminal sessions again.  Thanks for your help!

    Renaming the file at %appdata%\Roaming\code4ward\code4ward.RoyalTS.UserPreferences.config reset the UI back to defaults.  I was then able to re-customize the UI as I had it before and test.  The ad-hoc box on the quick launch works consistently again.

    Thanks for your help!

    Hi Jason! Thanks for getting back to me. Not sure what happened exactly but I'm glad you got it working. Please let us know if you have any other issues or questions.

    Update: The Problem came back again.  For some reason after all this reset something "broke" again and now it is back to being annoying opening multiple terminal windows.  I'm thinking it may have something to do with using a different Putty.exe config instead of the OOB terminal setting.

    Looks like if the Putty plugin is default and Embed method is 'window' it gets problematic, but with the embed method set to Client area, it has gone back to working without having to reset my customization file again.

    Thanks for letting us know, Jason. Looks like there's not much we can do. Re-parenting external windows is quite a hack which isn't really a supported scenario. We are already aware of a couple of "side effects". I guess we can add this one to that list.

    Thanks Stefan, I'm pretty sure that Window embed method is a default setting, I don't recall changing that when I changed my terminal plugin to default to Putty but I could be mis-remembering.

    Yes, you are correct, "Window" is the default embed method. A side effect of the "Client" embed method in PuTTY is, that the cursor is not blinking.

    Login or Signup to post a comment