Start a new topic
Solved

Color Palette Import Problem

Hi


When I try to import a color palette for a terminal session - Rebex/ Putty


Then I get an error message

Failed to import terminal color palette "Path on a G drive in windows" unknown file format (Unexpected error encountered while parsing a value: <.Path '',line0, position 0.)


Screen dump attached

Same error for putty, copying from the clipboard works for windows themes


2 questions 

1.  how do you fix this

2. are there any downloadable light-colored themes in the RTCP format (Royal Terminal Color Palette) 


Than you for your time


Hi Harm,


we were able to reproduce the behavior and will look into it.

Thanks for bringing this to our attention.


Best regards,

Christoph


Hi!


We fixed the issue for the next release.


As a workaround you could try to open the .itermcolors file in a text editor, remove the <!DOCTYPE ...> (line 2) from the file, copy the contents to the clipboard and use the Import Clipboard feature. Let me know if this works for you.


Regards,
Stefan

Import works fine from the clipboard if you remove line 2. (just need to make sure you get the whole line, as in notepad it wrapped the line and I only got half of it. GVIM worked fine)


Does not solve my problem if trying to get a white background color theme in Rebex.

 (I am almost there) how can I get a similar affect to putty where I can just chose system colors



That worked (not the first time) you need to ensure that it does not wrap that line. The first time I did it failed.


Does not solve my number one problem, which is I want a light-colored background. Even when I pick these pallets like Iterm2 Alabaster it still comes in with a dark background. I am trying to use rebex but I come from putty and just use the system colors checkbox to get a white background.

I think the issue is that Rebex handles colors a bit differently as PuTTY. In PuTTY you can define a dedicate background and foreground (text) color - independent from the ANSI palette. Rebex doesn't allow that. Instead, you need to switch to Color Scheme mode "Custom Palette and Text Colors" in the drop down menu and assign background and text color from the ANSI color palette:

Thanks that worked, I also need to uncheck invert cursor color so I could see the cursor

Glad I could help!

Login or Signup to post a comment