Start a new topic
Solved

1Password Integration Error

Hi there,

we are having issues implementing 1Password via the dynamic folder.

We have python with the required modules installed, as well as the 1Password CLI binary.

As soon as I refresh the folder I get the following error:

image

Do you guys have any idea? Thank you.


Here are some version infos:

python: 3.10.4

1Password CLI: 2.1.0

Royal TS: 6.1.50425

I tried the 1Password CLI Version 1 and also Version 2.0.1. Didn't work either. The python modules are definitely installed. I tried importing them via python shell and got no error. I can also login via the op.exe. The account is being created fine. There is an email coming from 1Password saying I registered a new device. Is there some compatibility issue wirth some python module? Is there a logfile where I can dig into this deeper?
Thanks.

 

Another Update: macOS seems to be working. Windows is the problem here. Used different machines. Disabled Windows Defender etc. No change in the behaviour.

Last Update for today: It definitely must have something to do with the recent changes due to 2FA. As soon as I activated 2FA for the account I used for the dynamic folder, it started working for Windows. Maybe you guys can take a lot, as I am not the programming guy. Hope all of the information I provided will help. Thanks a ton.

Hi Carsten,


as mentioned in my reply to your ticket, the problem was reproduceable on Windows machines, when 2FA is disabled.

In the meantime, you can use the previous version of the script, I sent you in the ticket reply.


Thank you very much, we will look into the script!


best regards,

Christoph Mühlberger

Hi Carsten,


good news!


Our lead dev reworked the script and I can confirm that it works for Windows & macOS, whether MFA is activated or not.

I attached the script to this post.

Alternatively, you can import it via the Royal TS/X sample gallery.


Have a great day!


best regards,

Christoph

rdfe
Login or Signup to post a comment