Start a new topic

Royal JSON Secure Gateway Fingerprint Object Missing

I'm trying to add a fingerprint to a secure gateway and it doesn't appear to be working.

I've tried:

{"Type": "SecureGateway","Name": "Jump Server","ComputerName":,"Fingerprint": "00:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00"}

 and going one layer deeper and it still doesn't pick it up

{"Type": "SecureGateway","Name": "Jump Server","ComputerName":,"Properties":{"Fingerprint": "00:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00"}}


Anything I'm missing? Known problem? This works on SSH connections just fine under the properties of course.

Royal TS Windows Version: 6.0.50824


the property is called "SecureGatewayFingerprint" and needs to be specified in the "Properties" array.

When in doubt, I recommend to just create an object (like the secure gateway) in a test document, use it, so that the fingerprint gets saved and check the .rtsz file XML to see which properties are written.

Let me know if this helps.


Thanks Stefan.

That was my next idea. I was looking in the documentation here: but I didn't see it like SSH Object. Did I miss it there, or is it missing?

For next time like you said, I'll look at the XML and then post if I don't see it there or the documentation :)

Thanks again

The SecureGatewayFingerprint property doesn't appear in the docs because it's marked as hidden by mistake. I will fix this and go through other hidden properties to ensure most relevant properties are documented.

Sorry for the inconvenience!



Login or Signup to post a comment