Start a new topic

How to find reason for RoyalTS 6 not starting

I'm unable to start RoyalTS 6 after installing. The application starts, but immediatly exits. I haven't been able to find any logs or windows events to indicate why this might be happing. Where should I look to find some information on why it is immeditaly exiting?

Hi Robert,

I'm sorry you are experiencing issues with Royal TS V6. 

First, please check if there's a "hanging" invisible instance of RoyalTS.exe still running in the task manager. If so, kill the process and try to start it again. You may also try to restart your computer to ensure no zombie process is running in the background.

If this doesn't resolve the issue, try renaming the file %appdata%\code4ward\code4ward.RoyalTS.UserPreferences.config and start Royal TS again.

Lastly, check in the Event Log under Application if you can see anything logged.

Let me know if this helps.


Hi Stefan,

So I tried what you suggested and this did not help.

However I didn't notice in the log for the endpoint security used on our corporate laptops that was a item referring to the blocking of the launch of power-shell. So I lodged an incident with my IT department on the assumption that maybe RoyalTS was trying to run a power shell script on startup and this was causing the endpoint security to terminate it.

I received the following back

The root cause: The application wtabletserviceisd.exe invoked another application (powershell.exe). A Deny Policy Action was applied. 
We have whitelisted the application, it should work now.

Which confused me, as a quick googling of wtableserviceisd.exe, suggests that is for a wacom tablet, which I don't have.

Regardless the whitelisting has solved my problem and now I can run Royal TS.

Hi Robert,

this is indeed very strange. The mentioned executable shouldn't have anything to do with Royal TS. Not sure what's going on here but I'm happy that Royal TS now runs on your machine.


Login or Signup to post a comment