Start a new topic

[beta] Rebex Terminal unable to connect to Diffie-Hellman-Group1-Sha1

Regarding the new Security Configuration UI in Rebex Terminal, Advanced > Security. Even after checking/reordering all the Key Exchange Algorithms, I am no longer able to connect to some older Cisco Switches that are using Diffie-Hellman-Group1-Sha1. I was previously able to connect to these in v5 by checking the box for "Allow insecure SSH Key Exchange Algorithms" under the old Advanced Security tab. I do see in the Key Exchange Algorithms that there's a diffie-hellman-group1-sha1 after hovering over the item, but the Friendly Name shows as "Diffie Hellman with Oakley Group 2 and SHA-1 hash"

Tested on latest Royal TS 6.00.20507.0 BETA


Thanks,

Zach


Hi Zach,


would you mind submitting a support ticket about that. We would like to have more information on how to reproduce the issue.


Thanks,
Stefan


1 person likes this

Hi Stefan,


I did previously put in a support ticket for it, ticket #49280. It had a few things combined into the ticket for beta feedback/bugs. I can open up a new separate one if that would be preferable.


Thanks,

Zach

I went ahead and submitted a new support ticket for it, ticket #50749. Thanks for reaching out


Thanks,

Zach

Thank you, Zach. It might take a while until we look into it. We just released our new versions and once the dust settles, we will see what we can do. We may require some logs or so but since you have a ticket open now, it should be handled by our support staff.


cheers,
Stefan


1 person likes this

Hey Stefan,


Thanks for reaching out with an update. I'll continue using v5 for the time being. Happy to provide any logs or data needed to get this resolved.


Thanks,

Zach

I am having the same issue attempting to connect to multiple Cisco UBR 10k's after upgrading to version 6.  I can still connect to Cisco 6509's but not the 10k's.  I am using SSH and diffie-hellman-group1-sha1 keys.  I also tried to go back and use the v5 version of Royal TS but it is now showing as unlicensed and my new v6 license wont work with it.  What now?


Jack

Jack,

If you still have an old email with the v5 license key, it should work. I had mine saved in a text file and was able to re-activate my v5 after running into the same unlicensed/shareware mode


Thanks,

Zach

I think we found the culprit. The next release will hopefully fix the issue.


2 people like this

Awesome, thanks for the update. Eagerly awaiting that next release!


Thanks,

Zach

Login or Signup to post a comment