Start a new topic

VNC issue

Getting the below event in the log.  I am trying to connect to an Apple device.  I can connect fine with ultravnc or vncviewer.

Any ideas?

Severity: Information
Date and Time: 12/16/2020 16:57:35
Action: ViewerCore
Object ID: e5809edc-ba2d-4e2b-87d2-c5a9ca8f0dac
Object Name:
Object Type: VNC Connection
Local User: ROYALSVR\<user>
Local Host: ROYALSVR
Remote User:
URI: <ip>
Plugin Name: VNC (based on integrated TightVNC)
Plugin Version: 5.03.61110.0
Plugin ID: 01a6d238-c621-40f5-8479-029f38b1c691
This stop is caused by reason:Specified key is a known weak key for 'DES' and cannot be used.


Hi Nicholas,

I haven't seen this error before and I also cannot reproduce it with my test machines. Can you provide more details on how to reproduce it. Do I need a specific mac OS version, for example?


It’s Mac OS Big Sur. I have two machines a MacBook Pro and Mac mini. Both are doing it.

I just did some tests with Big Sur and for me it's working as expected. When do you see this issue? Right away from the start or during a remote session?

As soon as I try to connect. Let me try from another Mac and see what happens.

We just released a new version of Royal TS. Can you update and see if the issue is resolved?


wow  update seems to have fixed it.

one more question.

i tried on the mac (big sur).  i can connect direct via vnc to the other mac.  same with windows.

but if i am remote and use the royal server gateway, windows works fine with the new update.  Mac (check for updates none available) keeps saying "an error occurred while opening tunnel: username or password is incorrect".  

i dont see any logs on MAC so its hard to troubleshoot since windows works and i know the username and password is correct.  

Hi Nicholas,

glad the update has fixed your issue.

Regarding the Royal TSX related problem, please post in the Royal TSX (for macOS) forum or open a dedicated support ticket, so that our mac Team can look at the issue.

Thank you!


Well 2 years latter, this is happening again. 

Connecting a TightVNC server on windows 2022 from royal. I get the same error :(

Despite the name of the host, the client is a windows 10.

Login or Signup to post a comment