Start a new topic

RDP Saved Credentials

I love using Royal TSX on Mac!  On the Windows servers I regularly RDP to, I was able to use a saved credential and launch the server from a double-click on the shortcut.


However, now that I am trying Royal TS on PC with the same servers, I get a popup specifying "The server's authentication policy does not allow connection requests using saved credentials" and I have to enter the credential again.  This happens with Windows RDP and any other RDP managers I have tried on PC.


I am wondering how Royal TSX on Mac was able to get around this, and if there is some way I could make it work on PC.  Anyone have any ideas?  I was planning on purchasing a full license of Royal TS if I could get the trial to work like Royal worked on my Mac.


Thanks!


Hi Eddie,


I think the behavior is different because Royal TSX on the Mac is using FreeRDP, which is an open source RDP client. Windows is using Microsoft's RDP ActiveX control which ships with Windows (as many other RDP managers do). It seems that the FreeRDP implementation does not honor the Group Policy setting. As far as I know, the only way to make this work on Windows is to disable the policy which prevents using credentials upfront.


Regards,
Stefan

Thanks Stefan!  This is exactly what I needed to know.  I will continue using Royal TSX when on Mac, but I found another client to use on PC that uses FreeRDP and lets me bypass this annoyance.

You're welcome. Out of curiosity, which client on Windows are you using?

I found Remote Desktop Manager by Devolutions.  I like it pretty well so far!

Login or Signup to post a comment