Start a new topic

Web Page plugin auto open external application

Recently after doing a fresh install of Windows 10 I've ran in to a problem.

Whenever I have a WebPage (based on chrome) that launces an external application - could be Citrix Receiver, ConnectWise, RDP gateway file and the like - instead of opening the external receiver application, Royal TS insists on downloading the file contents to a selected folder.

I cannot find a setting that overrides this - could be like the IE "Run" instead of "Download" prompt - so I suspect that I may have done something to my Royal TS in the past to get around this, but I have no idea what it was.


Hi Steen!

As far as I know, this has always been the case but maybe the vendor of the Chrome component has changed something. Do you remember which version of Royal TS behaved like that?


I’ve had it working as intended for 3 years until today where I did the fresh install. On all versions of Royal TS 4 through 5. Currently on the latest stable build. I won’t rule out the possibility that I did some kind of registry hack in the past to get it working, but I clearly forgot to write down what I did.

Hmm, interesting. I just checked the code and I cannot find anything which could launch the file automatically. I'm not really sure how you got this behavior.

Oh joy!

I have another PC where it is working as well .. (my private desktop), you can be sure, that if I found a hack I've applied it there as well it's on version 5.2.60304 at the moment.

I will dig into this. Do you want anything in regards to Royal TS configurations? Regedit files? Log files? Config files? Let me know and I'll supply it.

Well, as I said before, I can't think of anything which can change the behavior. If you figure it out, I will be interested in the setting/hack you applied to check how this could affect the code. Maybe it's something specific to the chromium engine which never shows in any of our code paths...

It looks like it could be a chromium setting/hack. I can confirm on my freshly installed PC that the IE plugin is capable of launching external applications whereas the Chrome plugin is not.

I will dig into what chromium hacks I may have made on my desktop PC and get back in this thread whenever I have found the solution.

A follow up question.

Can Royal TS change from "Download file" to "Open file"? Currently i'm testing on a .ica file that is supposed to be opened with Citrix Receiver.

In Google Chrome, if I first time download the file I can choose "Always open files of this type", where after a recurring download will automatically open the file, which triggers the corresponding application to open correctly in Windows. This is the behavior I'm looking for. As far as I remember, I did something to make Royal TS change this behavior.

Could it be listening to settings from Google Chrome or Windows 10?

As I mentioned before, in our code we always prompt for a file name/location when a file is downloaded. I honestly have no idea how you were able to override this behavior. You mentioned that 5.2.60304 behaves like you wanted. Can you download and install this release from here and try it:

That did not help :/

Here are the findings of tonight.

I build a VM with a fresh install of Windows 10 2004 so I could test everything.

1. Installed 5.2.60304 and took a snapshot

2. Updated to 5.3.31012 and took a snapshot

On (1) and (2) I got ConnectWise to work as intended. Chromium sends the correct url to the background listener service, so that the ConnectWise client starts correctly without Royal TS downloading anything. This behavior is now also true on my Laptop from the original post. All I had to do was install the client from a "real" browser.

On (1) I installed Citrix Workspace via Windows 10 Store. And tried to invoke a Citrix Desktop. This didn't work, instead it just downloaded an .ica file. Did the same on (2), same result. Then I uninstalled the Citrix Workspace from both (1) and (2) and afterwards installed it with the .msi installer from the citrix website. It turns out, that those versions are different (Windows 10 Apps runs in some kind of restricted sandbox that causes all sorts of trouble, when communicating from third party apps). Now it works as well for Citrix connections. Royal TS now invokes the Citrix Receiver application instead of downloading the .ica file.

From the findings above it looks like there is no hacking any software. It is merely a question about installing the right components from the correct places (basically, avoid anything from the Windows 10 Store).

As of now, all my automated logins are working for ConnectWise and Citrix (hooray), RemoteApp and Desktop Connection still forces a download of a .rdp file when using Chrome engine, however this old technology is probably soon to be deprecated, and runs fine with the IE plugin it seems, which allows ActiveX to handle the invocation RDP connections without downloading anything.

I believe that this solved my problems for now.

Thanks for taking the time to share your solution! I'm sure other users will find this very helpful.


Login or Signup to post a comment