Start a new topic

Log Files not Closed Properly when "Keep remotely disconnected tabs open" is Checked


  1. Options > Behaviour > Tabs and Connections > Keep remotely disconnected tabs open checked
  2. Terminal session A (SSH) with following settings in Properties > Advanced > Logging:
    Path: local path configured
    Create Sub-Directory with Connection Name checked
    Auto-Start Recording when Connected checked

Steps to reproduce
  1. Start terminal session A
  2. Type something in session
  3. Terminate session remotely (e.g. Ctrl+C or "logout")
  4. Go to dashboard of terminal session A
  5. Select created log from top bar of dashboard

Experienced behaviour
  • Log is not displayed in lower area of dashboard
  • Log is displayed with size "0 B" even the file contains data (verified by file system inspection)
  • When pressing the "Play / Pause" button an error message is shown

Cannot play selected file: The process cannot access the file 'C:\Users\Manuel\Documents\Logs\Royal TS\opnsense-prod\20200720204723-opnsense-prod.ans' because it is being used by another process.


Expected behaviour
Log should be displayed in lower area of dashboard and file size should be filled with actual file size of log file.

Additional information
When disabling the setting "Keep remotely disconnected tabs open" the behaviour is as intended.

(30.2 KB)
1 Comment

Hi Manuel,

thank you for reporting the issue. The fix will be available in the next maintenance release.


Login or Signup to post a comment