Start a new topic

ssh remote command with password

I am using ssh remote command with

ssh -p <port> -l <user> <host>

The jump host is configured via key access.

If I start the connection I get prompted for the password on the remote session and after entering the password I can successfully connect.

However, I have not found any way to automatically provide the password. I know it is possible as on windows with MobaXterm I can do it.

But as ssh does not have a parameter for command-line password I cannot leverage on the $EffectivePassword$ (or I don't understand how this is supposed to work)

Also, the remote user is different from the jump host user.

I've tried trigger but didn't seem to trigger on the password prompt.

Is there a way to provide the remote password via stored credentials?

Hi Johannes,

you could provide the username and password for the final destination in a (protected) custom field and use $CustomFieldXX$ to refer to it.

Let me know if this helps.


Hi Stefan,

thanks for the reply. I've put the password in a protected field, however since I have no way to enter the password at command-line level, how do I pass it into the prompt?
The prompt looks like this: 

<remoteuser>@<host>'s password:

That's why I thought I could use a trigger and pass in a text, but a trigger seems to be working only after the password has been entered and the session is established.



Hi Stefan,

minutes after the post (as usual) I got it working. Trigger actually has to send the \n after the password as well. So for others to benefit in the future:

Put the password in a protected field.

Use a regex to check for the prompt.

As parameter put in the $CustomField$\n

Tick the instant box, then add.

Thanks, Stefan for the hint with the protected field.


Glad it's working now - and thanks for sharing the details!


Login or Signup to post a comment