Start a new topic

Royal TSX forgets monitor placement

I use two external monitors connected to my closed MacBook Pro. When I use Royal TSX it is in Full Screen mode on the second monitor.

When I restart the OS and when I restart Royal TSX it appears in Full Screen mode on the first monitor. The expectation is what it will stay on the monitor it is initially assigned to.

Other applications I use such as Airmail, and Apple's Numbers will follow this convention.

Hi Jackson,

I cannot reproduce this here. Does the issue only occur after a reboot or every time you quit and restart Royal TSX?

Do you quit Royal TSX using "Quit and Keep Windows"?



I can reproduce this error every time I restart my computer or quit and reopen Royal TSX.

When I restart, I will go to the Apple menu and select Restart from the menu with all my applications open. When everything comes back up, Royal TSX has shifted from the "right" monitor to the "left" monitor while still in full screen mode. The left monitor is the one that has the Dock if that makes a difference.

When I quit, I will just use Command+Q when Royal TSX is the active application. I'm not specifying any modifier keys. Royal TSX will go from being maximized on the right monitor before quitting to opening full screen on the left monitor after being opened again.

I can see when I hold down the Alt key while the Royal TSX menu is open that the bottom command changes to "Quit and Close All Windows" but this is something I am not intentionally triggering.

I have the same problem. I have 3 monitors with the default on in the middle, and Royal TSX always starts up in that monitor. Also, if I quit when in full screen it still starts in windowed mode.

Hi Johnny,

yes, the main window placement after restarting your computer is a bug and we'll be looking into solutions to fix this in one of the next releases.

Regarding restoring the full screen state after quitting and re-launching the app: Instead of a regular "Quit", open the "Royal TSX" menu, hold the option/alt modifier key on your keyboard and select "Quit and Keep Windows".



I'm running (Beta) and my default Quit option is "Quit Royal TSX"

When I hold down Alt/Option, that changes to "Quit and Close all Windows" which is the opposite of what I'm looking for and what you stated. So am I safe to assume the default is already "Quit and Keep Windows"?

I close Royal by right clicking on the icon and selecting Quit. The Alt/Option closing does not work there.

If I quit via the "Quit and close all windows" it does start up in full screen, but still on the wrong monitor. 

Since I always want Royal to start in full screen mode it would be helpful if that was an option in the settings.




I'm using TSRoyal in the same way...dual monitor. How are you able to get a connection to open in full screen without blacking out your primary screen? I've had this issue ever since the introduction of OSX Spaces. I've tried every combination of using Spaces, windowed mode, etc. But, nothing allows me to have the RDC connection on my secondary monitor with access to my OSX desktop on the main screen.

The closest I've come to is just using windowed mode, and option-clicking the green window ball in the connection header. This goes nearly full screen with the exception of the window bar and TSR connection bar.

@James: Like mentioned in the other thread, if you're using "Displays have separate Spaces" you shouldn't have a problem with displays blanking out when using single-screen full screen RDP connections.


do you still experience this issue?



Yes. This issue still happens 100% of the time on multiple devices.

Hi guys,

we've just released a new beta version which contains some fixes for window placement issues.

Could you please give the beta a try and let me know if it works for you?

You can get the beta here.



Seems to work better. 

Quit and start in windowed mode starts the windows on the correct monitor. 

Quit and Keep Windows in full screen mode starts in windowed mode on the wrong monitor but then moves to fullscreen on the correct monitor. 

I still want an option in the settings so I can default to "Quit and Keep Windows".




Just revisiting TSX since you announced the new beta--I must have missed your last question from last December. Unfortunately, I'm still having the same issue. To your suggestion of selecting 'Displays have different spaces' option, this affects the rest of my workflow too much. My preference is to have spaces respect all monitors. Separating them means switching spaces multiple times instead of once to get my displays in the correct configuration.

Luckily, this is not a major deal for me — yet. I was able to find an old version of Microsoft's RDC v8.0.39 which continues to work the way I prefer--an RDP connection filling only a specified screen in a specified space without blacking out or hiding the contents of the other monitor.

But, one day this version of RDC will be deprecated/no longer work and I'll need a replacement that works. If TSX can get there I'll switch sooner than later. As for now, even with this most recent beta, I'm still better off with the old version of MS RDC.

I'll keep my eyes here. But, it sounds like I have too insignificant of a request to be promoted for change.

@James: If you only need the RDP connection to occupy a single screen you can already specify which screen it should open on. You can also drag and drop the full screen session to different spaces in mission control.

Login or Signup to post a comment