Start a new topic

SFTP not working


It seems that since the RoyalTSX upgrade I had recently I can't connect to my sftp connections. I get the attached error. I open the same document in windows and the connection works just fine.  I recently switched from a windows laptop to a mac and this used to work but now does not. 

Has anyone else had this issue?

found this in console,

=x= Error - Plugin - Rebex.Net.SftpException: A supplied user name not accepted by the server. ---> Rebex.Net.SshException: A supplied user name not accepted by the server.

  at Rebex.Net.SshSession.mlxr (System.String ahg, System.String ahh, System.Boolean ahi) [0x0034b] in <6eed1ee1e36b4ed9b3052dd60b1a20b5>:0 

  at Rebex.Net.SshSession.mlxs (System.String ahj, System.String ahk, Rebex.Net.SshPrivateKey ahl, Rebex.Net.SshGssApiCredentials ahm, System.Boolean ahn) [0x007d6] in <6eed1ee1e36b4ed9b3052dd60b1a20b5>:0 

  at Rebex.Net.SshSession.Authenticate (System.String userName, System.String password, Rebex.Net.SshPrivateKey privateKey) [0x0003f] in <6eed1ee1e36b4ed9b3052dd60b1a20b5>:0 

  at Rebex.Net.Sftp+adkc.afib (System.String all, System.String alm, Rebex.Net.SshPrivateKey aln, nuhi alo) [0x0001e] in <71558a0ff34b4b5a9c21a773d17ccae3>:0 

  at Rebex.Net.Sftp.hxsn (System.String pu, System.String pv, Rebex.Net.SshPrivateKey pw, nuhi px) [0x00105] in <71558a0ff34b4b5a9c21a773d17ccae3>:0 

 --- End <…>

even though the username is correct, i have uninstalled the plugin, reinstalled and still same error.

MBP 2019 OS catalina macOS 10.15.1 (19B88)


unfortunately we're not able to reproduce this issue here.

Could you please let us know the exact versions of Royal TSX (for macOS) and Royal TS (for Windows) you're using?

Also, does the connection work properly when using the sftp command from a command prompt?



RoyalTSX Version (Stable)

I have a document I share between mac and windows. It has SFTP connections and this all works fine on windows. 

The document connects to a PAM server and then to the actual linux node. 

In the properties of the connection the computer name is the PAM server and in Advanced > SFTP the custom command is root@server.fq.dn /usr/libexec/openssh/sftp-server

I can connect just fine under windows so I don't think it's the document or setup of the connection. This afternoon when I get off work I'm going to install the previous version of royaltsx and see if it still happens.

Not seeing previous comment so I'll repost this.

I was able to downgrade to RoyalTSX version 4.1.1000 and my sftp connections came back. 

I was on version 4.2.1000 when the SFTP connections stopped working. I share the document between windows and mac so I know it's not the document because it works fine in windows. 

To me it seems like the plugin isn't passing the credentials correctly. 

My sftp connections connect to a PAM server then to the actual node. 

computer name PAM SERVER

Advanced > SFTP root@node.fqdn /usr/libexec/openssh/sftp-server


the Windows and Mac versions share the same underlying code for file transfer connections. We recently updated the 3rd party library we're using for file transfer connections. So if there's an issue with that library you would see it on both, Royal TSX and Royal TS. However, both apps would need to be up to date. If you're still using an older Royal TS (for Windows) version you might not see the issue because it doesn't contain the updated component.

Please ensure you're running the latest Royal TS (for Windows) version and let me know if you can still connect with the Windows version or if it breaks too if you update.

In any case, please let me know the exact version numbers you're using for both apps.



Hey Felix,

So the current versions I have installed for win/mac are as follows and both work just fine.

Win 10 - Version 5.0.61707

Mac Catalina - Version (Stable)

If I upgrade Mac to version 4.2 that's when it breaks. If I download version 5.1.61104 for windows and load the same document with the same sftp connections. I get the attached error when using an SFTP connection. so it appears broken in both new versions. Even though the credentials haven't changed something isn't passing them correctly. Even if I manually type a username and password that is valid, it still doesn't log in.

I've also added the xml section of the sftp setup, replaced server info with dummy info.

(4.22 KB)


thx for checking the Windows version as well.

A couple of questions:

  • Does the issue also occur if you remove the custom command?
  • Could you please check your server-side log for any errors?




So for the server it's connecting to, the PAM server, I do not have access to it to check the log files. 

If I just try to sftp to the server directly on port 22, I am able to connect successfully, however we must go through a PAM(Privileged Access Management) server for logging purposes. 

The PAM server uses our network credentials and then connects to the server you are needing access to with the user in the custom command. 

Hi there,

sorry for the delay! We've been debugging this with several customers and came to the conclusion it's likely caused by a change introduced in Royal TSX 4.2.

In this release we started preferring keyboard-interactive authentication over password authentication for Secure Gateways and File Transfer connections. This change has now been reverted and instead we now offer a setting to turn it on optionally.

Could you please give the latest beta release (and of course the updated file transfer plugin) a try and let me know if the issue is fixed for you?

You can get the beta here:




Since upgrading to the latest stable versions of Royal TS and Royal TSX, I have had the same issue but only for SSH/SFTP connections configured via a specific secure gateway (an old SunOS Sparc workstation). The Royal TSX beta provided above has fixed the issue for me.



Perfect! Thx for letting us know!



I am wondering if the beta version that fixes this issue has been released? I just downloaded version for Mac and the SFTP still doesn't connect. I had to roll back to 4.1.1 to get sftp to function again. 

The fix is currently only available in the beta releases. We're working hard to release a stable version soon but I can't yet give you an ETA unfortunately.

1 person likes this


I just downloaded Version for MacOS and the SFTP issue has been resolved when trying to use saved credentials to connect. 

Login or Signup to post a comment