Start a new topic

SSH Protocol Version Selection

Is there already a readily compiled guide for changing SSH settings for connections that I've configured in Royal TSX? I've tried to find some documentation on that as the Royal apps have a bit of a learning curve, but I'm afraid I didn't see such a thing.

I'm using a document originally created with Royal TS which should prefer SSH2, but I never had good results with that (if a host needed SSH1, it would never fallback to that). Whenever I try to connect to one of these hosts that require SSH1 from within Royal TSX I get the following:

Protocol major versions differ: 2 vs. 1

 I've tried poking around under the connection properties, but haven't seen anything to allow me to even specifcy SSH preference, let alone set it outright.

Any pointers would be appreciated!

1 Comment


Royal TSX uses the SSH client that ships with macOS to establish SSH connections. You can pass any additional parameters that you need to the SSH client in the "Advanced - SSH - Additional SSH Options" properties.

That being said, support for SSH protocol version 1 has been removed from the SSH client that ships with macOS in High Sierra. So unless you're running macOS 10.12 Sierra or lower, there's no way to open a connection to a SSH1 server using the built in SSH client.

You can check if your SSH client supports protocol version 1 by opening and entering "ssh -1 YOURHOST". You'll likely see a message along the lines of "SSH protocol v.1 is no longer supported".

The best option would be to update your remote host to use SSH version 2. If that's not possible, you might want to look into installing an OpenSSH client with support for SSH protocol 1. See this thread for pointers on how to achieve that:

Hope that helps,


Login or Signup to post a comment