Start a new topic
Implemented

Ad Hoc connection through ssh gateway

Would be nice if when right-clicking Ad-Hoc connection from an existing connection to be able to specify to connect through the ssh gateway.


The context menu works and lets me start the connection, but it brings up the Credential Picker instead of using the credentials specified.


Hi Jason,

this is probably because the "Prompt for Credentials" option is checked (one level higher). Can you uncheck this option and try again?

Regards,

Stefan

Hi Jose,


this feature is already available.


Regards,
Stefan

Hi Stefan,


No, let me clear, I meant using "Connect Ad Hoc".  Sometimes I have an open connection already to a server, and I want to open an ad hoc connection using a different credential.  So I use the "Connect Ad Hoc" method with prompt for credentials.  Works fine with non-gateway connections, but when using a gateway, it doesn't work.


Hi Jose,


can you provide more details on what you mean by "it doesn't work"? Do you see an error/warning in the log? Are credentials not passed on? Can you inspect the resulting ad hoc connection and find out what was not set correctly?


Thanks,
Stefan

Hi Stefan,


Okay, I see that this may be a bug and not really a feature request, but might be two things, bug and feature request.  Here is what is happening.


What I mean is if you have an existing connection opened to host "A" using a gateway host, then when trying to open a second connection to host "A" via the right-menu click "Connect with Options" --> "Connect Ad Hoc", it fails to connect.  Message on the screen says "Opening Tunnel".  But I believe it is trying a direct connection, or maybe it is trying to open tunnel using the same local port that the previous connection is using, I don't really know, just speculating.  And if have an existing connection opened to host "A" using a gateway host, then simply right-menu click "Connect with Options" --> "Connect through gateway" --> [pick the gateway]  doesn't do anything.  Presumably because the connection is already open.


My request is that "Connect Ad Hoc" should provide options on how the ad hoc connection is done: is it done via a gateway, or is it done normally.  Also, while at it, I think this is either feature request or bug (let me know if need to submit a new request).  Same problem with "Connect SFTP" or "Connect SCP".  They don't appear to use the gateway host.

Hi Jose,


I just tried a file transfer connection with "Connect Ad Hoc" which is configured to use a secure gateway. It seems to work fine for me. The secure gateway settings are correct and the connection is successful.


I also tried using RDP and prompt for credentials. The tunnel is established correctly and I get prompted for the new credentials.


Can you verify that you are running the latest release of Royal TS V5? If the latest release does not work, please open a support ticket with more details about your setup, scenario (screenshots) and maybe a short video which shows how you establish those connections.


Thanks,
Stefan

Login or Signup to post a comment