Start a new topic

Key Sequence only in Royal TSX

One of my connection is a website that redirects me to a different URL for login. The redirected URL is unique per login attempt.

I've successfully configured an automatic key sequence to log into the site instead of relying on AutoFill.

One problem I'm having is that if something else takes focus or if I switch away to a different app before Royal TSX has executed the key sequence, it "types" and submits the username/password in whatever app is currently active.

I can't seem to find a way to restrict a key sequence to stay within Royal TSX. Am I missing something somewhere?

1 person has this problem

Hi Jackson,

many thx for providing that video.

We found a pretty embarrassing bug that basically caused web connection to always execute key sequences in the old "Keyboard Input Simulation" mode. So direct mode was actually never used and that's why you saw the issue of text being typed into other application.

We just released an update for the plugin which fixes that issue. After installing the update you should not be able to reproduce the issue of text being entered in another application. The problem that text ends up in another part of Royal TSX will still be present though and is unfortunately related to how WebKit handles key presses.



Thanks for getting that fixed so quickly. I'm more concerned about another app stealing focus than me being dumb and opening another TSX connection.

Hehe, yeah, definitely the worse scenario.

Did you already check if the issue is solved for you?

Yup, I did a quick test and the key sequence stayed in Royal TSX despite another app having focus. I also tried switching to a shell connection and the input still stayed within the web connection tab

Perfect, thx for letting me know!

Login or Signup to post a comment