Start a new topic

Adapt for multi-monitor setup / window management

When starting RoyalTS with auto loading of a .rtsz file, the pop-up asking for the file password prevents us from moving the RoyalTS window around. In a multi-monitor setup, it can be cumbersome. Right after typing the password, if an RDP session is autoloading, it uses the screen resolution and layout of where that window is, and often I have to reconnect to the RDP session after moving the RoyalTS main window.


This often happens when I have to move from my office, to my home office or to the road, where I have different monitor setups…

1 Comment

Hi Philippe,

these popups are "modal dialogs", which are required to show before we can further process UI updates without interference with other stuff. Unfortunately these modal dialogs prevent you from moving the main window. This is a limitation/behavior of Windows itself which we cannot circumvent. If you have smart reconnect enabled for your RDP connections, Royal TS should automatically reconnect when you move and resize the window to the other screen and adapt the desktop size. Can you try this and see if this improves your workflow?


Login or Signup to post a comment