Start a new topic

Workaround for "The server's authentication policy does not allow connection requests using saved credentials"

"The server's authentication policy does not allow connection requests using saved credentials"


Is there a way to let RoyalTS fill in the credentials on the challenge after a few seconds to work around this? Like an auto-reconnect on connection loss? My team has to deal with almost 150 servers, and we're annoyed like heck about this near useless policy. I have automated away our problem with the high rotation rate of the servers by using dynamic folders and linking them to just 9 password groups, but this one problem eludes me...


I argue that the workaround does no harm because a simple PowerShell script is able to do work around this by waiting 4 seconds, as well as the RoyalTS on the MAC and some other products as well... 


So why can't this be a setting in RoyalTS, and give us users the choice to ignore this SERVER SIDE policy and (re)connect after a few seconds?


Or what about giving us the option to use a key sequence task to fill in the challenge popup IF ith happens? II now use a Legato Streamdeck to fix this, but there has to be a better way in RoyalTS to do this!

Theo Ekelmans
NL

1 Comment

Hi Theo,


may I kindly ask why you have this policy in place if it is such a huge problem for your environment. I would argue that the security implications of sending the credentials to the server in a "controlled" environment are less than risking typing passwords through keyboard input simulation into an arbitrary window - especially when it's so easy to mistakenly switch the focus to another app or web site. The damage you can make is much bigger. That is one of the reasons we are hesitant to implement this. Another reason is that dealing with multiple popups makes it difficult or even impossible to identify the correct popup. This could lead to other unpleasant side effects.


Regards,
Stefan

Login or Signup to post a comment