Start a new topic

DPI issue with RDP connections

I realize that RoyalTS uses the ActiveX control when using RDP sessions and not the RDP Client (mstsc.exe) and that doesnt implement the updated protocol settings that newer versions of the RDP client support.

What about implementing something like this in RoyalTS and the ActiveX implementation?  Link below:


1 Comment


please check this KB for more information about Royal TS on high DPI systems:

To sum up:

  • make sure you do not override any DPI settings on RoyalTS.exe using the file explorer properties.
  • Make sure you disable display scaling as mentioned in the KB
  • If you run Royal TS on a system with RDP 8 or later and connect to a system with RDP 8 or later, the zoom factor in the remote session will be automatically applied according to your client's DPI setting (200% when working with a 192dpi setting)

Let me know if you have any further questions.


Login or Signup to post a comment