Start a new topic

SFTP: Provide a setting to configure the preferred host key algorithm


We have an SFTP server running CrushFTP 7.8 which we are unable to use RoyalTS to connect to at present. Whenever we try to connect, we receive an error:

An error occurred while executing the action 'Connect'. Details: Negotiation failed. Server signature is not valid. Do you want to reconnect?

I've tried tweaking all the settings, especially the Security settings, to no avail... however after Googling the error message, I've found a specific thread on the Rebex forums relating to CrushFTP and this error message.

From what I can understand, the suggestion is that Rebex uses DSA as the default key type, but RSA is preferred. Use PreferredHostKeyAlgorithm = SshHostKeyAlgorithm.RSA to get around this error.

I can't work out how to do this within RoyalTS. Does anyone have any advice on how we might be able to do this?


1 Comment

Hi Mike,

there's currently no way to change this setting. That's why I moved your post to the Ideas forum and changed the title.

We will look into it and see if we need / can provide a UI for that.


Login or Signup to post a comment