Start a new topic

Remote Desktop DPI Scaling: RoyalTS vs Windows

I've noticed recently that if I connect to a anything using Remote Desktop in Windows using MSTSC the scaling seems to be correct but when I connect using RoyalTS everything is enlarged. This has caused me some issues when using software in Remote Desktop connections in RoyalTS because everything is so large it's hard to see everything as intended leading to more scroll bars, etc...

Windows:

image


RoyalTS:

image



To answer the other question: in the past releases we didn't properly scale the session dimensions when the app was DPI aware. Since more and more users are using high DPI displays, we've seen more and more support requests in this area to fix the issue. It seems that the now "correct" behavior seems to bother users who got used to the way it was before. That's why we are considering a "initial scale factor" setting so that users can set it to whatever they prefer.


1 person likes this

Initial on every RDP connection ? Or initial at global application settings ? Second variant is preferable i think.

I was thinking about a setting on a per connection basis (similar to the zoom level of a web page using chromium). To apply it on all connections, you could use bulk-edit and set the default settings accordingly - which would be a one time task. When I implement a global setting, I bet it wont take long until the first users are complaining about that and want a per connection setting ;)

What about both ways ?

Bulk editing is a hard work when you have many folders if i am right.


P.S. It seems zoom doesn't work in hyper-v oses

i have acronis backup opened and cmd

i see how the size of cmd windows changes but count of strings and font size in acronis window doesn't changes no matter how many times i press zoom +, acronis is bigger than i'd like to see it.

You can easily bulk-edit all rdp connections even from different folders. you simply enable the option to show all objects from the subfolders in the dashboard and sort/filter by remote desktop connection type. you can then simply select all your connections in the doc.


As far as I know, zoom only works if the remote OS implements the necessary APIs. Not all Windows versions support DPI zoom. So the issue with Hyper-V is that you are essentially connect to a "virtual console" session which isn't aware of any OS beneath. I'm afraid there's nothing on our side we can do to make that work. MS needs to implement "zoom" support when connecting to a hyper-V host's console session.


DPI awareness has it's limitation because MS didn't really implemented it fully. See also: https://support.royalapps.com/support/solutions/articles/17000027792-run-royal-ts-on-high-dpi-displays


If DPI awareness limitations are a showstopper for you, I recommend to uncheck "Disable display scaling on high DPI settings". In this mode, the OS fakes a 96DPI system for the window and scales the window as it were a non high DPI process. The result is blurry icons but the sessions should be scaled correctly in any situation.

I see, and at what version of royal TS the behavior of DPI work changed ? I may try the previous, because the blurry items is not the way i want to use.

I think that would be all before 5.2 but I please keep in mind that there were some nasty GDI object leaks and some cross threading issues with bitmaps in 5.1.x and 5.0.x. Depending on how you use Royal TS, those versions may be unstable.

Yeah the issue must be with the RDP ActiveX control, perhaps something has changed with it rather recently.


I've since removed XPExplorer scaling and tried Windows 10 custom scaling at 115% but the issue persists no matter what options are set with RoyalTS or RoyalTS.exe file properties. When using MSTSC to RDP the issue doesn't exist.


Perhaps I'll just have to run at 100% DPI for now on my laptop until the RDP ActiveX control issue is fixed.


MSTSC @1440x900

image


RoyalTS @1440x900 (DPI seems fairly high as you can see there's scroll bars added)

image


RoyalTS @Auto Expand/Full Screen

image



I can see you specified a custom desktop size: 1440 x 900. Since your DPI scaling is 115% the resulting resolution will be 1656 x 1035

Can you try to calc the value before scaling: 1252 x 782


Sure thing let me turn scaling back to 115%

Btw, if you switch scaling in Windows, always make sure you at least log out and re-login. WinForms based apps like Royal TS don't like messing with DPI scaling during a session ;)

 Here's the result:


RoyalTS @1252x782

image


Yup! I always sign out/log off in Windows when changing the DPI scaling.

So is this the desired size?

Unfortunately no, everything is still abnormally enlarged within the RDP session in RoyalTS making navigation/reading incredibly difficult (lot's of scroll bars) if you compare is to the MSTSC screenshot @1440x900.


For the time being I'm going to go back to 100% DPI in Windows.


RoyalTS @1252x782

image


MSTSC @1440x900

image


Login or Signup to post a comment