Start a new topic

Unexpected "Select or Specify Credentials"

I have been using Royal TSX 4.2.1 on Mac OS 10.13.6 for a while now to connect to servers at work using smart card.  It connects fine to few of my Windows 2008 and 2012 Servers and never get the popup for "Select or Specify Credentials" - having to deal with credentials directly on the windows servers - just select the user on the server and put in my passcode.  I got new Windows 2016 servers and no matter what i do i get the prompt of "Select or Specify Credentials" even before it establishes connection and i don't know what to use there.

I tried creating  new connection using the same settings that i had for my working connections.  I even tried duplicating the existing working connection.  when that didn't work, i even tried using the existing connection just by changing the computer name.  I keep getting this "Select or Specify Credentials" and I don't know what to use.  Any help will be greatly appreciated.


"If you currently are trying to use smart card redirection but can't get it to work, the first thing you might want to try is to enable "TLS Encryption" in the "Advanced - Authentication" settings of your RDP connection's properties." - worked.  Thank you

Hi Prashant,

currently, the FreeRDP plugin does not support Smart Card redirection via NLA. Unfortunately, that means that if the server requires NLA, it is not going to work. I am sorry to be the bearer of bad news!

Login or Signup to post a comment