Start a new topic

Royal TS 5.1 under Wine (Ubuntu 19)

Just FYI for others trying the same thing. The 5.1 version does not seem to run under Wine (4.0.3). Running the `msiexec` against the installer seems to work, but once installed, running the `RoyalTS.exe` generates an error message. See attached picture.

I'm not expecting a solution since Linux is specifically not supported. I purchased a new copy of Royal TS 5.1 as one of my enterprise clients relies on it and I want to use the same software. They use it to access the various online servers on DigitalOcean, AWS, etc; all of which run Ubuntu.

For me, it is not a big deal. I have a licensed copy of Win10 I run in a VirtualBox container; so I will install it there. It makes Royal TS kind of a pain to run, but life goes on.

I do find it odd that a software product aimed at server admins who often connect to Linux machines is, itself, not available in Linux. If this were a game or something, I'd understand: but the target audience is admins...

Just FYI: running Pop_OS 19.10 (an Ubuntu variant) that ships on the System76 laptop I use.

1 person has this problem

For me the 6.01.50722.0 Version sadly doesn't start anymore with wine..

I've got it running at xubuntu 20.04


but RDP doesn't work - 

"royal ts install remote client is not supported"

and it's terrible slow.. can we do something ?

John Dupuy, what other software did you install into the container?

I can start Royal TS 5.2, I get an error during launch which I click ignore and then I can see the main screen.

The software does appear to work, I can go into options, create connections etc...

I'm using KUbuntu 19.10 with Crossover Linux 19.0.1.

I installed into a 32bit Win 7 container with: C++ 2015 and .NET Framework 4.7.2.

What other software did you install in the container? I think I'm extremely close to having a Royal TS running with Crossover but suspect I'm missing some component.

Screenshot attached, notice the problem with icons:

Hi John,

the crash seems to originate from a WMI call to read out the OS info. The latest (5.2) release should handle this exception and Royal TS shouldn't crash because of that. Can you check?



I was not able to due to an error that followed when I tried. See attached error pic.

I've attached the error file if that helps.

I certainly understand having limited resources.

(2.07 KB)

Hi John,

did you submit the crash report? I can check to see why the crash happens and maybe there's a solution for this.

Regarding a linux version, please check this KB:

In short: "porting" Royal TS/X to Linux is a huge effort and a lot of the technologies we are using on Windows and Mac must be ported or rewritten. We do not have the resources to do this.


Login or Signup to post a comment